[Global] Outlook add-ins might not work
Incident Report for CodeTwo
Postmortem

Microsoft has officially confirmed the problem was on their end, and published communication about this incident to the Service Health section of the Microsoft 365 Admin Center for all affected tenants (Communication ID: EX829938). You can find it in the “Issue history” section. We also pasted it below:

Users may be unable able to use already acquired add-ins within the Outlook desktop app and Outlook on the web

User impact

Users may have been unable to use already acquired add-ins within the Outlook desktop app and Outlook on the web.

More info

The issue could have been seen in either the new or classic Outlook desktop app, as well as within the Outlook mobile app.

Scope of impact

This issue may have affected any user of already acquired add-ins within the new or classic Outlook desktop app, Outlook on the web, and the Outlook mobile app.

Root cause

A recent code change resulted in a bug affecting the service that gets add-in manifests into the host, which led to this impact.

Next steps

-We’re (Microsoft) reviewing our code change testing and validation procedures to assess areas for improvement to avoid similar issues from being reintroduced in the future.

- We’re (Microsoft) refining our understanding of the code bug by reviewing what the code change intended to do and analyzing how it led to this behavior, so that we can better understand how it caused the impact.

Posted Jul 24, 2024 - 09:21 UTC

Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 21:02 UTC
Update
We can confirm most of users are no longer affected by the issue. Some users might need to restart Outlook or refresh OWA to fully fix the problem.
Posted Jul 22, 2024 - 20:49 UTC
Update
The fix has been deployed. Some customers already notified us the problem is solved (so did our Q&A team and SOC). We are currently helping Microsoft monitor for any further issues.
Posted Jul 22, 2024 - 20:08 UTC
Monitoring
The Outlook product group is currently deploying a fix to production. It should be available worldwide within 45 minutes.
Posted Jul 22, 2024 - 19:14 UTC
Identified
Microsoft engineering team has reported: We have discovered an issue with the backend service that provides add-ins, and we have engaged the backend team to address this ASAP. We are making progress and will let you know as we get more information from them.

Just as a reminder - Outlook add-ins are currently affected due to a Microsoft issue, but server-side (cloud) signatures are added normally. Only signatures added by the Outlook add-in might not work.
Posted Jul 22, 2024 - 17:07 UTC
Investigating
Microsoft is currently experiencing a problem with Microsoft 365 add-ins. Some add-ins are not working or working intermittently for a subset of users. All add-ins may also completely disappear from the Microsoft store occasionally. This is a Microsoft issue, and it's not limited to CodeTwo since we observe that other add-ins (even Microsoft native add-ins) are also affected. As a result of this problem, CodeTwo signatures might not be added in Outlook (desktop, OWA and mobile).

Server-side (cloud) signatures are added normally. Only signatures added by the Outlook add-in might be affected.

We're currently investigating this with Microsoft.
Posted Jul 22, 2024 - 16:33 UTC
This incident affected: Australia East (Outlook add-ins), Canada East (Outlook add-ins), North Central US (Outlook add-ins), North Europe (Outlook add-ins), West Europe (Outlook add-ins), West US (Outlook add-ins), UK South (Outlook add-ins), Germany West Central (Outlook add-ins), and UAE North (Outlook add-ins).