[Germany West Central] Outlook add-in issues - signatures might not be added again
Incident Report for CodeTwo
Postmortem

Microsoft was able to identify and fix the problem on their end earlier today. The problem was caused by incorrect routing of traffic for Outlook add-ins and calendar free/busy information as result of a recent update Microsoft performed in this region. We have confirmation from most of affected customers that the issue is no longer present in their environments. The official communication about the problem (ID EX744850) was posted by Microsoft in Microsoft 365 Admin Center - it can now be found in Health/Service health/Issue history under the following title: Some users may have been unable to leverage Outlook add-ins or view Calendar free/busy information.

For your reference, here’s the entire message from Microsoft that was posted there:

Microsoft Reference: EX744850

Issue Status: RESOLVED

Issue Description: Some users may have been unable to leverage Outlook add-ins or view Calendar free/busy information.

More Info: Users may have been unable to leverage Outlook add-ins or view Calendar free/busy information.

Final Update: 20/03/2024 09:12:00 AM – Microsoft have successfully deployed the aforementioned change within the affected infrastructure and after a period of monitoring confirmed that issue is no longer occurring.

Scope of impact: Impact was specific to users who were serviced through the affected infrastructure.

Root cause: A recent update exposed a code regression that was leading to incorrectly rerouted traffic for Outlook add-ins and calendar free/busy information requests.

Next steps: Microsoft are reviewing their update procedures to better identify similar issues during their development and testing cycles.

Posted Mar 20, 2024 - 19:32 UTC

Resolved
As Microsoft is actively looking for the solution, we are closing this incident because it is not CodeTwo related. We were able to confirm that affected users cannot use any of their Outlook for Windows web add-ins including Microsoft's own Viva Insights add-in. We will provide more information in post-mortem communication when we learn more from Microsoft. If users in your organization experience Outlook add-in issues, please open a service request with Microsoft Support.
Posted Mar 15, 2024 - 17:02 UTC
Investigating
We can see the problem with Outlook add-in reported yesterday (https://status.codetwo.com/incidents/988w7914l855) is back for a subset of users in Germany West Central and might affect even customers who updated Outlook for Windows to the newest version (which temporarily resolved the problem yesterday).

This problem is related to Microsoft infrastructure and backend code, which CodeTwo has no control of, and it affects any Outlook web add-in in Outlook for Windows (also from other vendors). Microsoft has been working on resolving this issue since yesterday, but so far the problem has not been identified by them. CodeTwo is currently helping Microsoft with repro steps and finding the culprit.

If your users are affected and their signatures are not added as they type an email, please inform them to use Outlook on the web (OWA) until the issue is resolved, or you can use the server-side mode only for your organization (which will add all signatures after emails are sent - irrespective of the add-in functionality).

Add-ins in Outlook for Mac, OWA, iPhone and Android seem to work correctly across the entire user base.

The next update will be provided when we learn more about the problem.
Posted Mar 15, 2024 - 08:20 UTC
This incident affected: Germany West Central (Outlook add-ins).