[North Europe] Email processing delays
Incident Report for CodeTwo
Resolved
This incident has been resolved.
Posted Feb 05, 2020 - 09:35 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 05, 2020 - 09:19 CET
Investigating
We are currently investigating email processing issues in North Europe. A subset of users may experience delayed email delivery. Email signatures are added normally.
Posted Feb 05, 2020 - 09:12 CET
This incident affected: North Europe (Mail flow).