[North America] Microsoft Exchange Online Protection issues
Incident Report for CodeTwo
Resolved
The incident has been resolved. All CodeTwo services were operational during the incident. All messages were delivered with signature(s). More information on the Exchange Online Protection issue can be found under EX252124 in the Microsoft 365 admin center.
Posted Apr 22, 2021 - 15:41 UTC
Monitoring
The situation is improving. We are continuing to monitor the services. Further information can be found under EX252124 in the admin center of your M365 tenant.

The next update will be provided in 30 minutes or as events warrant.
Posted Apr 22, 2021 - 15:34 UTC
Update
Microsoft tweeted: We're investigating a potential issue with Exchange Online mailflow in North America. Further information can be found under EX252124 in the admin center. https://twitter.com/MSFT365Status/status/1385245913053020164

We are monitoring the situation. The next update will be provided in 30 minutes or as events warrant.
Posted Apr 22, 2021 - 15:00 UTC
Investigating
We are currently investigating an issue caused by a degraded performance of Microsoft Exchange Online Protection (EOP) which may lead to delays in email delivery for a subset of customers in North America.

The next update will be provided in 30 minutes or as events warrant.
Posted Apr 22, 2021 - 14:51 UTC
This incident affected: West US (Mail flow), Canada East (Mail flow), and North Central US (Mail flow).