[North America] Admin Panel not loading for some users
Incident Report for CodeTwo
Resolved
This incident has been resolved.
Posted Sep 07, 2022 - 20:25 UTC
Identified
The problem is caused by Microsoft due to Azure Front Door service connectivity issues. Microsoft just reported on status.azure.com:

Starting at 16:10 UTC on 07 Sep 2022, customers using Azure Front Door could be experiencing connectivity issues. This could also be impacting customers’ ability to access other Azure services that leverage Azure Front Door, this includes the Azure Management Portal. We are investigating a spike in traffic as a potential cause. This traffic spike has subsided and we are currently working on remediating the residual impact. We are recovering a number of nodes that are showing intermittent connectivity issues. For customers who are experiencing connectivity issues, retries are likely to be successful. Most customers should be seeing recovery at this stage.
Posted Sep 07, 2022 - 18:36 UTC
Investigating
We are currently investigating a problem of login pages (and Admin Panel) not loading for some users in the Canada East and North Central US geolocations. Some users might be unable to login and use the Admin Panel to manage their subscriptions. Signatures are added normally and delivered to final recipients.
Posted Sep 07, 2022 - 17:36 UTC
This incident affected: North Central US (Admin Panel (emailsignatures365.codetwo.com)) and Canada East (Admin Panel (emailsignatures365.codetwo.com)).