[Europe] Email processing delays

Incident Report for CodeTwo

Resolved

This incident has been resolved.
Posted Mar 18, 2020 - 11:00 UTC

Monitoring

Looks like the issue has been mitigated. We're monitoring the services actively.
Posted Mar 18, 2020 - 10:50 UTC

Update

Most geos are fully operational now. We're still investigating North Europe.
Posted Mar 18, 2020 - 10:46 UTC

Update

We are continuing to investigate this issue.
Posted Mar 18, 2020 - 10:39 UTC

Investigating

We are currently investigating this issue.
Posted Mar 18, 2020 - 10:35 UTC
This incident affected: North Central US (Mail flow), North Europe (Mail flow), West Europe (Mail flow), UK South (Mail flow), and Germany West Central (Mail flow).