Microsoft issues with Azure Active Directory
Incident Report for CodeTwo
Resolved
This incident has been resolved.
Posted Mar 15, 2021 - 22:05 UTC
Monitoring
We're seeing first signs of recovery. Microsoft is currently rolling out a mitigation worldwide.

Details of the incident may be found in M0244568 on the Microsoft 365 Admin Dashboard and on Twitter: https://twitter.com/MSFT365Status/status/1371546946263916545?s=20. Mailflow is not affected. Signatures are added normally.
Posted Mar 15, 2021 - 21:45 UTC
Identified
Microsoft identified an issue with a recent change to an authentication system. They're rolling back the update now. Details of the incident may be found in M0244568 on the Microsoft 365 Admin Dashboard and on Twitter: https://twitter.com/MSFT365Status/status/1371546946263916545?s=20. Mailflow is not affected. Signatures are added normally.
Posted Mar 15, 2021 - 20:23 UTC
Investigating
We are currently experiencing temporary problems with accessing CodeTwo Email Signatures for Office 365 Admin Panel and Manage Signatures App, due to an outage of Microsoft Azure Active Directory service. Your emails processed by CodeTwo Email Signatures for Office 365 service are not affected in any way, and are delivered without interruptions. Signatures are added normally. Details of the incident may be found in M0244568 on the Microsoft 365 Admin Dashboard and on Twitter: https://twitter.com/MSFT365Status/status/1371546946263916545?s=20.
Posted Mar 15, 2021 - 20:11 UTC
This incident affected: Germany West Central (Signature management (app.codetwo.com), Admin Panel (emailsignatures365.codetwo.com)), Canada East (Signature management (app.codetwo.com), Admin Panel (emailsignatures365.codetwo.com)), UK South (Signature management (app.codetwo.com), Admin Panel (emailsignatures365.codetwo.com)), West Europe (Signature management (app.codetwo.com), Admin Panel (emailsignatures365.codetwo.com)), North Europe (Signature management (app.codetwo.com), Admin Panel (emailsignatures365.codetwo.com)), North Central US (Signature management (app.codetwo.com), Admin Panel (emailsignatures365.codetwo.com)), Australia East (Signature management (app.codetwo.com), Admin Panel (emailsignatures365.codetwo.com)), and West US (Signature management (app.codetwo.com), Admin Panel (emailsignatures365.codetwo.com)).