[Global] Auto replies incorrectly considered as spam and not delivered to recipients
Incident Report for CodeTwo
Resolved
We have confirmed this is a solely Microsoft issue (not related to CodeTwo in any way) and that it most likely concerns a subset of Microsoft 365 tenants. All CodeTwo services have been operating normally during the time of the incident. If you believe your tenant is affected by this Microsoft issue, please contact Microsoft support.
Posted Jul 27, 2023 - 07:57 UTC
Update
Microsoft is looking into this issue. From what we have gathered, the problem concerns Outlook/Exchange native auto replies only. Even if CodeTwo is switched off (bypassed), auto replies from affected tenants usually land in junk folders due to them being sent from the high-risk delivery pool with IP range 40.95.0.0/16, which is not a part of official "spf.protection.outlook.com".

Only auto replies are affected. Other emails are processed and delivered normally. Signatures are added normally. All CodeTwo services in all regions operate as normal.
Posted Jul 26, 2023 - 14:25 UTC
Identified
Our monitoring team have noticed that within the last 24 hours a large number of auto replies sent from Microsoft 365 tenants (everywhere in the world) has been considered as spam by Microsoft and thus not delivered to CodeTwo for final processing. Therefore, these messages have not been delivered to final recipients.

It looks like Microsoft, for some reason, started to classify auto replies (and maybe also other types of automated messages, but we have not been able to confirm this yet) as spam or phishing and send them through a new high-risk delivery pool with IP range 40.95.0.0/16 (which is not a part of official "spf.protection.outlook.com"). Since Microsoft native mechanisms indicate that these emails are high risk messages, our software security mechanisms reject them to protect our IPs reputation.

We have started working on this problem with Microsoft Premier Support now, but we recommend that you contact Microsoft support for assistance as well.

To apply a temporary fix, you can exclude auto replies from going through CodeTwo transport rule as described in this article (https://www.codetwo.com/kb/automatic-replies-should-not-be-processed/), but note that these emails may still get blocked/rejected on the recipient’s end, as most of mail servers do not accept emails sent through the high-risk delivery pool (https://learn.microsoft.com/en-us/microsoft-365/security/office-365-security/outbound-spam-high-risk-delivery-pool-about?view=o365-worldwide#high-risk-delivery-pool).

All standard emails sent by users are not affected by this problem. The next update will be provided within the next 4 hours.
Posted Jul 26, 2023 - 10:33 UTC
This incident affected: Australia East (Mail flow, Signature adding (rules processing), Signature management (app.codetwo.com), Sent Items Update, Admin Panel (emailsignatures365.codetwo.com), Azure AD data caching, Onboarding, Outlook add-ins, Autoresponder management (app.codetwo.com), Autoresponder sending (rules processing), Attributes manager (attributes.codetwo.com), My user info editor (user.codetwo.com)), Canada East (Mail flow, Signature adding (rules processing), Signature management (app.codetwo.com), Sent Items Update, Admin Panel (emailsignatures365.codetwo.com), Azure AD data caching, Onboarding, Outlook add-ins, Autoresponder management (app.codetwo.com), Autoresponder sending (rules processing), Attributes manager (attributes.codetwo.com), My user info editor (user.codetwo.com)), North Central US (Mail flow, Signature adding (rules processing), Signature management (app.codetwo.com), Sent Items Update, Admin Panel (emailsignatures365.codetwo.com), Azure AD data caching, Onboarding, Outlook add-ins, Autoresponder management (app.codetwo.com), Autoresponder sending (rules processing), Attributes manager (attributes.codetwo.com), My user info editor (user.codetwo.com)), North Europe (Mail flow, Signature adding (rules processing), Signature management (app.codetwo.com), Sent Items Update, Admin Panel (emailsignatures365.codetwo.com), Azure AD data caching, Onboarding, Outlook add-ins, Autoresponder management (app.codetwo.com), Autoresponder sending (rules processing), Attributes manager (attributes.codetwo.com), My user info editor (user.codetwo.com)), West Europe (Mail flow, Signature adding (rules processing), Signature management (app.codetwo.com), Sent Items Update, Admin Panel (emailsignatures365.codetwo.com), Azure AD data caching, Onboarding, Outlook add-ins, Autoresponder management (app.codetwo.com), Autoresponder sending (rules processing), Attributes manager (attributes.codetwo.com), My user info editor (user.codetwo.com)), West US (Mail flow, Signature adding (rules processing), Signature management (app.codetwo.com), Sent Items Update, Admin Panel (emailsignatures365.codetwo.com), Azure AD data caching, Onboarding, Outlook add-ins, Autoresponder management (app.codetwo.com), Autoresponder sending (rules processing), Attributes manager (attributes.codetwo.com), My user info editor (user.codetwo.com)), UK South (Mail flow, Signature adding (rules processing), Signature management (app.codetwo.com), Sent Items Update, Admin Panel (emailsignatures365.codetwo.com), Azure AD data caching, Onboarding, Outlook add-ins, Autoresponder management (app.codetwo.com), Autoresponder sending (rules processing), Attributes manager (attributes.codetwo.com), My user info editor (user.codetwo.com)), Germany West Central (Mail flow, Signature adding (rules processing), Signature management (app.codetwo.com), Sent Items Update, Admin Panel (emailsignatures365.codetwo.com), Azure AD data caching, Onboarding, Outlook add-ins, Autoresponder management (app.codetwo.com), Autoresponder sending (rules processing), Attributes manager (attributes.codetwo.com), My user info editor (user.codetwo.com)), and UAE North (Mail flow, Signature adding (rules processing), Signature management (app.codetwo.com), Sent Items Update, Admin Panel (emailsignatures365.codetwo.com), Azure AD data caching, Onboarding, Outlook add-ins, Autoresponder management (app.codetwo.com), Autoresponder sending (rules processing), Attributes manager (attributes.codetwo.com), My user info editor (user.codetwo.com)).