[Europe] Microsoft Exchange Online Protection issues
Incident Report for CodeTwo
Postmortem

Microsoft provided RCA regarding the issue under EX255429 in Microsoft 365 admin center.

Here’s the summary:

Title: Some users may have been unable to send and receive external email messages within the Exchange Online service User

Impact: Users may have been unable to send and receive external email messages within the Exchange Online service.

Final status: We've confirmed that cache has finished updating and the affected infrastructure has returned to service. After further monitoring, we've confirmed that this has resolved the issue.

Scope of impact: Impact was specific to users who were served through the affected infrastructure located in Europe.

Start time: Monday, May 10, 2021, 8:40 AM (6:40 AM UTC)

End time: Monday, May 10, 2021, 11:40 AM (9:40 AM UTC)

Root cause: A section of infrastructure, responsible for connecting email message attributes to end users, was not performing as expected due to the associated cache not fully updating.

Next steps: - We're reviewing our caching infrastructure to find ways to prevent this problem from happening again. This is the final update for the event.

Posted May 11, 2021 - 14:02 UTC

Resolved
This incident has been resolved.
Posted May 10, 2021 - 09:51 UTC
Update
We are continuing to monitor this issue. The impact seems to be low and only a subset of customers is affected.

The next update will be provided in 30 minutes or as events warrant.
Posted May 10, 2021 - 09:13 UTC
Identified
We are currently monitoring an issue caused by a degraded performance of Microsoft Exchange Online Protection (EOP) which may lead to delays in email delivery for customers in Europe. This is a Microsoft 365 issue - not a CodeTwo issue. Do not take any action - emails with signatures should be sent to final recipients once this issue is fixed by Microsoft.

The next update will be provided in 30 minutes or as events warrant.
Posted May 10, 2021 - 08:42 UTC
This incident affected: North Europe (Mail flow), UK South (Mail flow), West Europe (Mail flow), and Germany West Central (Mail flow).