[West Europe] Email delivery delays
Incident Report for CodeTwo
Resolved
This incident has been resolved.
Posted Oct 22, 2019 - 02:22 CEST
Monitoring
A fix has been implemented and we are monitoring the results. The majority of users are no longer affected by the issue.
Posted Oct 22, 2019 - 02:01 CEST
Update
We are continuing to investigate this issue. A subset of senders from this region may experience issues with delayed delivery.
Posted Oct 22, 2019 - 01:51 CEST
Investigating
We are currently investigating this issue.
Posted Oct 22, 2019 - 01:42 CEST
This incident affected: West Europe (Mail flow).