Email delivery delays - Microsoft is working on the problem
Incident Report for CodeTwo
Resolved
The incident affecting Exchange Online Protection servers in UK South, North Central US and West US has now been resolved by Microsoft. All emails are delivered without delays. If you need more information why your tenant was affected, please log a service request with Microsoft and provide the following service request ID as a reference: EX225938.
Posted Nov 06, 2020 - 08:43 UTC
Monitoring
All emails are now delivered without delays. We're monitoring the services actively.

Details of the incident may be found in SI# EX225938 on the Microsoft 365 Admin Dashboard and on Twitter: https://twitter.com/MSFT365Status/status/1324444676993277957.
Posted Nov 06, 2020 - 08:09 UTC
Update
Emails are now delivered without delays in UK South and West US geolocation. A small number of emails sent by a subset of users in North Central US geolocation may still be delivered with delays. Details of the incident may be found in SI# EX225938 on the Microsoft 365 Admin Dashboard and on Twitter: https://twitter.com/MSFT365Status/status/1324444676993277957. Email signatures are added normally.
Posted Nov 06, 2020 - 07:21 UTC
Update
The performance of affected Microsoft Exchange Online Protection servers in UK South geolocation is now improving, we're not seeing any email delivery delays. A small number of emails sent by a subset of users in North Central US and West US geolocations may still be delivered with delays. Details of the incident may be found in SI# EX225938 on the Microsoft 365 Admin Dashboard and on Twitter: https://twitter.com/MSFT365Status/status/1324444676993277957. Email signatures are added normally.
Posted Nov 06, 2020 - 06:34 UTC
Update
Microsoft engineers have applied a fix to mitigate impact. Details of the incident may be found in SI# EX225938 on the Microsoft 365 Admin Dashboard and on Twitter: https://twitter.com/MSFT365Status/status/1324444676993277957. Email signatures are added normally.
Posted Nov 06, 2020 - 06:00 UTC
Identified
A small percentage of emails sent by a subset of users may experience delays in email delivery due to degraded performance of Microsoft Exchange Online Protection. Details of the incident may be found in SI# EX225938 on the Microsoft 365 Admin Dashboard and on Twitter: https://twitter.com/MSFT365Status/status/1324444676993277957. Email signatures are added normally.
Posted Nov 05, 2020 - 22:34 UTC
This incident affected: UK South (Mail flow), West US (Mail flow), and North Central US (Mail flow).