[WestUS] Some emails with signatures are temporarily blocked
Incident Report for CodeTwo
Resolved
We confirmed that all emails have been delivered. All services are operational. We apologize for any inconvenience this issue may have caused.
Posted Jan 25, 2023 - 07:18 UTC
Identified
One of our services in WestUS was accidentally blacklisted at 3:59 AM UTC. We immediately forced a failover to a secondary resource which mitigated the problem at 4:21 AM UTC. Some emails that were sent with server-side signatures during this timeframe might have been delayed. We're currently checking if these emails were sent correctly. At the moment all services are operational.

We will be working with Microsoft to understand why this happened, and to prevent any similar situations in the future.
Posted Jan 25, 2023 - 04:56 UTC
This incident affected: West US (Mail flow).