Email deliverability delays due to degraded performance of Exchange Online email pipeline
Incident Report for CodeTwo
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 09:54 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 21, 2022 - 08:54 UTC
Monitoring
The messages are currently delivered without delays. We will now monitor the services.
Posted Jun 21, 2022 - 08:36 UTC
Update
We are seeing signs of recovery. Next update in 30 minutes.
Posted Jun 21, 2022 - 08:06 UTC
Identified
Microsoft has reported the following incidents in EAC:

EX394347 - https://admin.microsoft.com/Adminportal/Home#/servicehealth/:/alerts/EX394347
EX394348 - https://admin.microsoft.com/Adminportal/Home#/servicehealth/:/alerts/EX394348

We are monitoring the problem. We can see that lots of messages are delivered successfully after a second try. Next update in 30 minutes.
Posted Jun 21, 2022 - 07:52 UTC
Investigating
We are currently investigating this problem. Some messages cannot be sent from our service due to a degraded performance of a large number of Microsoft Exchange Online Protection servers. Our retry policies usually manage to successfully sent messages via different servers that are currently available, but it may take a few minutes for the messages to reach final recipients. Signatures are imprinted as normal. Next update will be provided in 30 minutes.
Posted Jun 21, 2022 - 07:42 UTC
This incident affected: West Europe (Mail flow), North Europe (Mail flow), UK South (Mail flow), and Germany West Central (Mail flow).