[North America] Email processing issues
Incident Report for CodeTwo
Resolved
This incident has been resolved.
Posted Feb 04, 2021 - 01:00 UTC
Update
The situation is slowly improving, although email delivery times are still far from perfect. It looks like a lot of Exchange Online Protection servers are affected which significantly slows down email processing for scores of users in North America no matter if they use 3rd party email processing services or not. We are continuing to actively monitor the situation. We have powered up multiple additional cloud instances on Azure to make sure our service is scaled up to guarantee max performance at the moment and also when Microsoft fixes the problem and releases the messages that have piled up.
Posted Feb 03, 2021 - 23:35 UTC
Update
Microsoft reports there is a problem with Exchange Online in North America: https://twitter.com/MSFT365Status/status/1357097859535888388. The tweet reads: We’re investigating an issue with Exchange Online for some customers in North America. Additional information can be found in the admin center under EX237654.
Posted Feb 03, 2021 - 22:51 UTC
Update
We are continuing to work on this. It seems to be a Microsoft performance issue. Messages processed by CodeTwo cannot be delivered back to Microsoft 365 in a timely manner. We're seeing signs of recovery though. More and more messages are being processed and the queues are getting smaller. All messages will be eventually delivered with signatures.
Posted Feb 03, 2021 - 22:09 UTC
Identified
The issue has been identified.
Posted Feb 03, 2021 - 21:50 UTC
Update
We are continuing to investigate this issue.
Posted Feb 03, 2021 - 21:48 UTC
Investigating
Users in this region may experience delays in email delivery. We're actively investigating the problem now.
Posted Feb 03, 2021 - 21:41 UTC
This incident affected: West US (Mail flow) and North Central US (Mail flow).